谁笨论坛

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

网盘分享动态:
资迅
资迅
生活
生活
娱乐
娱乐
互动
互动
小白免费下载学习绝密开发教程,全民申请公益分享大使!
仟图网苞图网千库网在线解析
688卡盟你值得信赖的保障,全网低价卡盟
查看: 137|回复: 5

[新手提问] cs1.6写的易语言辅助不能用 基址都对ce可用 易语言写出来没有效果

[复制链接]

已分享文件:0个

网盘今日赚:积分

发表于 2019-2-16 20:01:52 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转谁笨论坛

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x
.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 PID, 整数型
.程序集变量 基址, 整数型
.程序集变量 偏移1, 整数型
.程序集变量 偏移2, 整数型
.程序集变量 三, 整数型

.子程序 __启动窗口_创建完毕

PID = 进程取ID (“hl.exe”)
基址 = 读内存整数型 (PID, 十六到十 (“hl.exe+11069BC”))
偏移1 = 读内存整数型 (PID, 基址 + 十六到十 (“7C”))
偏移2 = 读内存整数型 (PID, 偏移1 + 十六到十 (“5d4”))
三 = 读内存整数型 (PID, 偏移2 + 十六到十 (“cc”))


.子程序 _按钮1_被单击

写内存整数型 (PID, 偏移2 + 十六到十 (“CC”), 到整数 (编辑框1.内容))

已分享文件:0个

网盘今日赚:积分

 楼主| 发表于 2019-2-16 20:02:59 | 显示全部楼层
主要是没效果 ,cs1.6  不会有内存保护的吧。为什么那  是不是模块的问题 超级模块9.2的
回复 支持 反对

使用道具 举报

已分享文件:0个

网盘今日赚:积分

发表于 2019-2-16 20:44:49 | 显示全部楼层
q577816667 发表于 2019-2-16 20:02
主要是没效果 ,cs1.6  不会有内存保护的吧。为什么那  是不是模块的问题 超级模块9.2的

换读写  超级模块读不出
回复 支持 反对

使用道具 举报

已分享文件:0个

网盘今日赚:积分

 楼主| 发表于 2019-2-17 12:44:08 | 显示全部楼层
Tianqi0 发表于 2019-2-16 20:44
换读写  超级模块读不出

能给我个能读写
的模块吗。我感觉我的读不进都
回复 支持 反对

使用道具 举报

已分享文件:0个

网盘今日赚:积分

发表于 2019-2-17 14:16:54 | 显示全部楼层
q577816667 发表于 2019-2-17 12:44
能给我个能读写
的模块吗。我感觉我的读不进都

精易模块 就行  超级模块也可以读的    基址 = 读内存整数型 (PID, 十六到十 (“hl.exe+11069BC”))         你这一步错了  你调试输出一下  数值不对的
回复 支持 反对

使用道具 举报

已分享文件:1个

网盘今日赚:积分

发表于 2019-2-19 01:21:33 | 显示全部楼层
基址 = 读内存整数型 (PID, 十六到十 (“hl.exe+11069BC”))  文本符号里面用+号有效果吗。你调试输出看看。。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则

QQ|小黑屋|手机版|Archiver|谁笨论坛

GMT+8, 2019-5-23 12:53 , Processed in 0.216471 second(s), 28 queries .

Powered by Discuz! X3.4 Licensed

© 2001-2060 Comsenz Inc.

快速回复 返回顶部 返回列表